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Selection was one of the first skills you developed as you began 
to use Photoshop, and one that you apply to almost every 
Photoshop project. Here we will begin with a quick review of 
selection and masking principles, improve selection by exploring 
the Color Range command, and then step through a series of 
guided exercises that will expand your masking repetoire.

ACE Preparation Topics

Working with masks
• 	 Save and load selections.

• 	 Explain how to create and modify a temporary mask by 
using the Quick Mask command.

• 	 Create and modify selections by using the Channels palette.

Selection and Masking Review

Photoshop uses selections and masks to either hide or reveal 
things—selections, pixels, and even layers. 

Selections can be thought of as simple masks that let 
you isolate and protect areas of an image as you apply color 
changes, filters, or other effects to the rest of the image. When 
you select part of an image, the area that is not selected is 
masked or protected from editing. 

Standard selections, such as those made with the Marquee, 

Lasso or Magic Wand tools, provide absolute selection—either a 
pixel is selected (100%), or it is not (0%). Masks such as Quick 
Mask, Alpha channels, Layer masks, and Clipping masks, select 
according to transparency. Think of masks as gradient selections 
ranging from black (completely hidden) to white (completely 
revealed or editable) so that each pixel in an image can be 
selected at any of 256 levels of opacity.

When you paint on a mask with the Brush or other painting 
tools, black hides, white reveals, and shades of gray partially 
hide or reveal. Any tools or commands that can be used on a 
grayscale image can be used to alter a mask. When you paint 
on a mask, you are not altering document pixels, just the mask. 
Whether you view the selection in Quick Mask or standard mode 
Photoshop uses the true selection, represented by the mask, to 
hide and protect parts of the document—not just what is inside 
the marching ants outline.

Masks can be saved with the document whereas marching ant 
selections cannot. However, when you choose Select > Save 
Selection, you are actually saving the selection as an alpha 
channel mask. Selections can be converted to and from alpha 
channels, which are saved with the document.

Photoshop masks can be divided into two categories:

•	 Selection-related masks include Quick Masks, Alpha 
Channels, and Type Masks.

•	 Visibility-related masks include Layer Masks, Vector Masks, 
and Clipping Masks. These masks can be applied to any 
layer but the Background.

Chapter 12: Selection/Masking Tips & Tricks
Overview
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The Color Range Command

To select effectively, most Photoshop professionals begin with 
the tool or command that initially isolates the majority of the 
desired part of the image, and then refine the selection by 
viewing it in Quick Mask mode, and painting on it.

Guided Exercise 12.1: Compare the Magic 
Wand with the Color Range Command
When you want to select image areas based on color, the Magic 
Wand is typically where new Photoshop users start.

The Select > Color Range command works similarly to the 
Magic Wand but offers more control and finesse. You can work 
in the Color Range dialog box with a number of tools and when 
you click OK, a selection will be generated. A selection created 
with Color Range will be more life-like than selections with the 
Magic Wand tool because it generates a mask-based selection, 
complete with gradients of selection.

The Color Range command selects based on the colors from all 
visible layers, but like any other selection, you will be editing 
only on the active layer.

1.	O pen globe.psd. It is inside the ch12 folder inside the 
student_files_3 folder.

We want to change all the red flowers to a lavender tone so 
that they are not so jarring.

2.	 Use the Magic Wand to select the red flowers.

a.	 Choose the Magic Wand tool with the default settings.

b.	 Zoom in to 100%, uncheck Contiguous and click inside 
one of the red flowers.

c.	 Click the Add to Selection button and continue 
clicking in reddish areas until you are pleased with your 
selection. Notice that it takes a fair amount of finessing 
with tolerance and the areas you sample to get a good 
selection of just the red and bright pink flowers.

d.	D eselect.

3.	 Use the Color Range command to select the red flowers.

a.	 Choose Select > Color 
Range.

b.	 Within the document 
window, click on one of 
the red flowers.

c.	N otice the whitish areas. 
Those are selections, 
based on the red color 
you just sampled.

d.	D rag the Fuzziness 
slider to the right. Notice 
that the selected areas 
enlarge. 

Fuzziness is like 
Tolerance on a slider. As 
you increase Fuzziness, it picks 
up more subtle detail, but if it 
is set too high, it may also pick 
up unwanted areas with small 
amounts of the sampled color.

With maximum Fuzziness, the 
gray regions here are partially 
selected.
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e.	 Reduce the Fuzziness to around 40, click 
the Add to Sample eyedropper, and 
sample more reddish areas.

You can typically get a more 
precise selection with more 
sample points at lower 
Fuzziness.

f.	 Experiment with the various 
Selection Previews at the 
bottom of the dialog box. The 
default None shows the actual 
image in the document window, 
and the quick mask view within 
the Color Range dialog box. 

g.	 When you are pleased with your 
initial selection, click OK.

4. Color Range tends to skip areas, 
especially as shown by the marching ants of the standard 
(selection) mode. Choose Select > Modify > Smooth to 
smooth out your selection. Smooth by only 1-2 pixels at a 
time to avoid over smoothing the selection.

5.	 Use your selection. Make a Hue and Saturation adjustment 
layer, and change the 
hue to tone down those 
red flowers. Because of 
the precision of the Color 
Range selection, the red 
petals on the ground and 
inside the reflecting globe 
also change.

 	 before				   after

Color Range Presets
The Select drop down menu reveals a 
series of preset samples. Unlike Sampled 
Color, these choices do not allow addition 
or subtraction of sample points, but the 
Fuzziness slider still works.

In the globe.psd image, sampling just the 
Reds is much faster, and gives at least as good 
or better results. Try it on your own. Highlights, Midtones, 

or Shadows 
work well to 
select just those 
regions, followed 
by an image 
adjustment. Here 
Midtones were 
selected, and 
lightened with 
a subtle Curves 
adjustment. 	 before			      after
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Out of Gamut is a very useful choice to use before converting 
an image from RGB to CMYK. Use this preset to select just those 
colors that are out of gamut, and then desaturate them slightly 
to bring them into gamut.

The difference is so subtle here you may need to zoom way in 
to see the changes. Notice that the top of the globe is slightly 
grayer. You can see it better if you do it yourself in Photoshop.

Remember the trick to selecting a colorful object on a solid 
background? Select the background with the Magic Wand, and 
then Inverse the selection. You can accomplish the same thing 
with Color Range by clicking the Invert box after you select the 
semi-solid background, such as the sky.

Layer Masks

If you want to get rid of a portion of a layer, you could always 
just erase it. The problem with this is that you’re stuck with the 
results. If you change your mind a day or week later, there’s 
no way to get the erased pixels back. Instead, you should use 
a layer mask, a mask associated with a specific layer, to non-
destructively hide portions of that layer. You can add a layer 

mask to any layer except the background.

There are two ways to add a layer mask to a layer:

1.	A ctivate the layer you want to mask, and click the Layer Mask 
icon at the bottom of the Layers Palette.

2.	 Choose Layer > Add Layer Mask and choose between 
Reveal All or Hide All. Reveal All is the same as clicking 
the Layer Mask icon, it will be a white mask. Hide All will 
give you a mask filled with black, blocking everything on the 
layer. This is useful if you want to mask most of the layer, 
and reveal only a small part of it.

Guided Exercise 12.2: Applying a Gradient 
to a Layer Mask
Sometimes it is nice to have one image flow into another. A quick 
way to do this is by layering one image on top of another, and 
then adding a layer mask with a gradient to the upper layer.

1.	O pen wind.jpg and lake.jpg. Both files are inside the 
ch12 folder inside the student_files_3 folder.

2.	 Choose Window > Arrange >Tile Vertically to place the 
images side by side. Do not worry about their zoom levels.

3.	 Combine the two images into one.

a.	A ctivate lake.jpg. 

b.	 Hold down the Shift key, and with the Move tool, drag 
the background layer of lake.jpg on top of wind.jpg. 

c.	 Release first the mouse button and then the Shift key to 
have the lake layer centered on top of the wind image.

d.	 Rename Layer 1 Lake, and close lake.jpg.

4.	 Save the image as gradient_mask.psd in the location of 
your choice. 

	 before			      after
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4.	 With the Lake layer active, click the Add 
Layer Mask button to add a mask to the 
Lake layer.

5.	 Reset your tools and foreground/background colors to their 
defaults, and then choose the Gradient tool.

6.	 Click the layer mask 
thumbnail to be sure the 
mask is active, and then 
make a linear gradient from 
the top to the bottom of the 
document window.

7.	 Experiment with other 
gradient shapes and angles 
until you get a merged image 
that pleases you.

8.	T hese photos were taken 
with a digital camera and 
have not been set up for 
printing. Adjust the (print) 
resolution in the Image 
> Image Size dialog box 
with Resample Image 
unchecked, and click OK.

8.	

Save the image, and print it if desired,

Clipping Masks

Clipping Masks use the pixels of one layer to determine the 
visibility of other layers. The bottom-most layer in the group, called 
the base layer becomes a mask for one or more additional layers 
included the clipping mask group.

In other words, wherever the base layer is transparent, the 
layer(s) above it in the clipping mask will not be shown. 
Wherever the base layer is not transparent, the other layers in 
the mask will appear.
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Guided Exercise 12.2: Create and Modify a 
Clipping mask
Clipping masks can be simple or elaborate. Graphic Authority 
makes several collections of creative edges and frames that work 
well as clipping masks. They are letting us use a few of their 
images here for free, and you can get more, royalty free and 
reasonably-priced, at http://www.graphicauthority.com. Be sure 
to let them know you are an SRJC student if you decide to order 
from them. OBTAIN THE FILES USED HERE FROM INSTRUCTOR.

1.	O pen lake.jpg. It is inside the ch12 folder inside the 
student_files_3 folder.

2.	 Check its size to see how big it can be printed at high 
quality.

a.	 Choose  
Image > Image Size.

b.	 With Resample Image 
unchecked, change the 
(print) Resolution to 300 
pixels/inch, or whatever 
is appropriate for your 
printer.

c.	N ote the Document Size in Width and Height. 

Lake.jpg has enough pixels for a high quality printout 
(300 ppi) of 7.57 x 5.68 inches. That means that its 
biggest standard size is 7 x 5 inches. That is the size we 
will use.

d.	 Click Cancel because you will not print this image as is.

3.	 Choose File > New and make a new RGB document that is 
7 x 5 inches, with a resolution of 300 ppi.

4.	 Save the file as clip.psd in the location of your choice.

5.	 Insert the lake image into clip.psd.

a.	 Zoom out to about 20% magnification, so that you can 
see the gray area of the document window beyond the 
document itself.

b.	 Choose Window > lake.jpg to bring the lake image 
forward and move it off to the side so that you can still 
see some of the clip.psd document.

c.	 Hold down the Shift key, and with the Move tool, drag 
the background layer of lake.jpg on top of wind.jpg. 

d.	 Release first the mouse button and then the Shift key to 
have the lake layer centered on top of the wind image.

e.	 Rename Layer 1 Lake, and close lake.jpg.

f.	 Choose Edit > Free Transform press shift, and drag 
the handles of the Lake 
layer smaller so that 
the layer fits within the 
document window as 
closely as possible without 
distorting it, and Commit 
the transformation. It will 
not fit exactly.
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6.	 Manipulate the edge image to provide a mask for the  
lake photo.

a.	O pen 031edge_edges5.tif. It is inside the Graphic 
Authority Samples folder inside the ch12 folder 
inside the student_files_3 folder. This high resolution 
grayscale image will become the clipping mask.

b.	 With 031edge_edges5.tif active, choose Image 
> Duplicate to duplicate the image, preserving the 
original.

c.	 Choose Image > Image Size again. 

d.	 With Resample Image unchecked, change the 
Resolution to 300 pixels/inch.

Notice that the edge image has many more pixels than 
the target clip.psd file. That’s because the professional 
quality Graphic Authority 031edge_edges5.tif has 
enough pixels to accommodate a larger than 8 x 10 
inch image at 300 ppi. This high resolution makes these 
edges very versatile.

e.	 With Resample Image checked, change the Width to 
8 inches and click OK. 

This will downsample the image so that it is closer in 

size to the target image. We left it a little larger so that 
you can transform it smaller if desired once you move it 
to the target document.

7.	 Use the Move tool to insert 
layer 0 in the edge document 
into the target clip.psd file 
like you did with the Lake 
layer (step 5 on the previous 
page).

8.	 Rename layer 0 to Edge, 
and change the layer order if 
necessary so that Edge is between 
the Background and the Lake layer.

9.	A ctivate the Lake layer and choose 
Layer > Create Clipping Mask. 

Alternately, you could Option (Mac) or Alt (Windows) click 
the boundary between the Lake layer and edge in the Layers 
palette to create the mask.  When you are in the correct 
position, you will see this double 
circle pointer: .

You can tell which layers use the 
clipping mask, because the name of 
the base layer that serves as the mask is underlined, and the 
thumbnails for the overlying affected layer is indented with 
an arrow to the left side of 
its thumbnail.

10.	If desired, you can free 
transform the base layer 
(Edge here) to refine its 
size and location, as shown 
on the next page. It does 
not need to be constrained.
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Here we scaled the Edge layer 
so that most of it fits inside 
the document window, but 
we let a little “hang out” in 
the lower right corner to add 
interest to the image.

11.	Instead of the plain white 
background, you can add a background image. Here we will 
add one of Graphic Authority’s antique papers.

a.	A ctivate the Background layer in clip.psd.

b.	O pen 002_Paper.jpg. It is inside the Graphic 
Authority Samples folder inside the ch12 folder 
inside the student_files_3 folder. 

c.	 With the Move tool, drag the Background layer onto 
the clip.psd document window.

d.	O nce there, change the layer name to Paper, and use the 
Move tool to position the Paper 
layer where you want it. Here, the 
large size of the Paper layer gives 
you flexibility to move it around 
until you find just the right location.

e.	O nce you have the Paper layer where you want it, 
Merge Down to make it the Background layer, and 
conserve file size.

12.	Save the document, if you haven’t already done so.

13.	Refine your image. Be creative. Here, we added a layer style 
to the Edge layer, and then changed its layer blend mode to 
Multiply to give it a sepia-like effect.
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Clipping Mask Examples
Clipping Masks provide a number of interesting ways to combine 
images. Type layers make very effective masks. Here is a nice 
example, made on an earlier version of Photoshop. Notice that a 
clipping mask can contain more than two layers.

Here’s a quick tutorial that uses a gradient fill layer to make a 
clipping mask: 
http://www.digitalmediadesigner.com/articles/viewarticle.jsp?id=
27264&afterinter=true

and a more extensive example, using Photoshop CS: 
http://www.graphics.com/modules.php?name=Sections&op=prin
tpage&artid=165

Vector Masks

As you saw in the previous chapter, vector masks can used to 
hide or reveal portions of layers. The main difference between 
the two is that vector masks use paths to hide or reveal parts 
of a layer while layer masks use pixels. That means that layer 
masks can provide much more subtle transitions, and vector 
masks offer crisper, sharper edges, making them especially 
useful for masking curved regions. Also, vector masks do not 
appreciably increase file size, but each layer mask increases file 
size by the same amount as an alpha channel. Vector shape 
layers can also be used as the base for a clipping mask.

Vector Mask Tutorial
This tutorial is a movie to show how to make and use a vector 
mask: 
http://www.techlearning.com/quickflicks/showArticle.jhtml?articl
eID=161502358

Guided Exercise 12.3: Use a Vector Mask
In this guided exercise you will use a path to mask part of an 
image, and compare that technique with a selection you will 
make with the Magic Wand.

1.	O pen ant2.psd. It is inside the ch11 folder inside the 
student_files_3 folder. (We’ll move it to ch12 in the next 
rev. of these notes.)

2.	 Show the Paths palette. It contains a premade path named 
ant that surrounds the metal ant sculpture. (For more 
practice with the Pen tool, try making your own.)

3.	 Click the ant path to activate it, and activate the Layers palette.

4.	D ouble click the Background layer, and name it ant. It is 
now a standard layer and can accommodate a mask.

5.	D uplicate the ant layer and name it shadow. Be sure the 
shadow layer is beneath the ant layer.

6.	 With the ant path active, and the ant layer active, choose 
Layer > Vector Mask > Current Path. 

7.	 Hide the Shadow layer and deselect any active paths to see 
just the ant on a transparent background. Notice that the 
curved vector masks are very smooth.

8.	 Hide the Ant layer and show and activate the Shadow layer.

9.	 With the Magic Wand at its default settings, click once in a 
dark part of the shadow to select most of the shadow. Add 
to the selection 
with a few more 
clicks, until you 
select all of the 
shadow. 

Do not worry if 
you also select 
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some dark parts of the ant, because the ant will cover them.

10.	Click the Add Layer Mask button at the bottom of the Layers 
palette to turn the selection into a layer mask. Now you see 
just the shadow, along with a few darker parts of the ant.

11.	Show the ant layer 
to see both the 
ant and its shadow 
on a transparent 
background.

12.	Highlight both the ant 
and shadow layers and 
choose New Group 
from Layers from 
the Layers palette 
menu. 

13.	Name the group 
ant + shadow 
and click OK.

14.	Choose File > Save As and name the edited document 
ant.psd in the location of your choice. Leave the document 
open for the next guided exercise.

Type Masks

The Horizontal and Vertical Type 
Mask tools are used to create 
selections in the shape of text. 

To use them:

1.	 Choose the desired tool from the Tool Box—you’ll find the 
Horizontal and Vertical Type Mask tools under the standard 
Type tools.

2.	 Choose your type options—font, size, etc.

3.	 Click in your document.

4.	T ype the desired text. You’ll see a mask forming in the shape 
of your text.

5.	 Press the Enter key. You’ll now a selection in the shape of 
your entered text.

The Type mask tools can provide some fun special effects, but 
because they just generate selections, they are not nearly as 
versatile as the Type tools, and their type prints at the resolution 
of the overall image because it is not scalable.

Guided Exercise 12.4: Use a Type Mask
In this guided exercise you will combine the ant group you made 
in the last guided exercise with a decorative background image 
from Graphic Authority, and then use a type mask and some 
other techniques to complete the image.

1.	O pen 002_Paper.jpg. This image has been downsampled 
to 7 x 5 inches and used with permission from the Portrait 
Papers Collection from the Graphic Authority: http://www.
graphicauthority.com/products/portrait-papers.html.

2.	 Be sure your foreground and background colors are set to 
the defaults and you have reset your tools.

3.	 With the Magic Wand tool, select the white background, and 
then Inverse the selection (Command/Ctrl + I) to select 
the paper itself. 

4.	T ype Command/Ctrl + Shift + J (New Layer via Cut) 
to place the decorative paper on its own layer above the 
background and name the new layer paper.

5.	A ctivate ant3.psd that you made in the last guided exercise, 
and with the Move tool drag the ant + shadow group on 
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top of the 002_Paper.jpg document window.

6.	 Save the document as ants_done.psd in the location of 
your choice.

7.	 Refine the image, saving as 
you go.

a.	 Move the paper layer 
slightly up and to the left, 
so that it is a little off 
center.

b.	A dd a slight drop 
shadow effect to the 
paper layer. Here are the 
settings we used.

c.	 Sampling a light and a dark color 
from the paper layer, place a linear 
gradient onto the Background layer.

8.	N otice that the ant’s shadow is too dark, 
and in the opposite direction from the 
paper drop shadow. Fix these problems.

a.	A ctivate the ant + shadow group, 
flip it horizontally, and reposition 
it into the upper left corner of the 
document.

b.	 Expand the ant + shadow group, 
activate the shadow layer, and 
change its blending mode to overlay.

9.	D uplicate the ant + shadow group, 
move the duplicate below the original 
ant, and scale it smaller.

10.	Make and use a type mask.

a.	 With the paper layer active, choose the Horizontal 
Type Mask tool and click just below the body of the 
upper left ant. 

As soon as you 
click, your image 
will be overlaid 
with a mask, with 
just a blinking insertion point showing. (Our mask here 
is aqua, not the default red.)

b.	 Pick a nice wide font, 
and a large font size 
so that your type will 
show up. (We used 
Overload, 67 pt.)

c.	T ype “Ant Invasion.” Select all the type, and change its 
font or size if necessary. 
Then commit the type just 
like with the regular type 
tool. The type mask becomes a marching ants selection.

d.	 Use the arrow keys if necessary, to reposition the 
selection where you want it.

e.	 Choose the Move tool, and 
arrow up and to the left 
slightly. This moves the 
selected pixels, and reveals the 
underlying background.

g.	 Hide your selection edges 
(Command/ctrl + H) to better 
see what the text looks like as you 
move it.

h.	 Choose Edit > Stroke and add 



Chapter 12: Masks and More Masks	 Page 156 

a slight stroke to the selection to make the type outline a 
little more visible.

i.	 Reveal your selection edges (Command/ctrl + H again) 
and deselect.

11.	Finish up the image as you like. We added one more tiny ant.

12.	Save and print if desired.


