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Web Resources

Course web site 
http://online.santarosa.edu/course/homepage/?811

Adobe in Education: Academic pricing, tutorials, and other 
resources for learning Photoshop and other Adobe products: 
www.adobe.com/education

National Association of Photoshop Professionals (NAPP) 
www.photoshopuser.com 

Planet Photoshop: http://www.planetphotoshop.com

Ben Willmore’s Ultimate Photoshop Guide:  
http://www.benwillmore.com/ultimateguide

ExamAids—software to help you prepare for Adobe 
Certification: http://www.examaids.com

Creative Studio’s Photoshop page:  
http://www.creativepro.com/software/home/57.html

Stock.XCHNG, “the leading FREE stock photo site:”  
http://www.sxc.hu/

Adobe Certified Experts (ACE)

What is an ACE?
“An Adobe Certified Expert is an individual who has 
passed an Adobe Product Proficiency Exam for a specific 

Adobe software product. Adobe Certified Experts are eligible to 
promote themselves to clients or employers as highly skilled, 
expert-level users of Adobe software. The ACE designation is a 
recognized worldwide standard for excellence in Adobe software 
knowledge.” (Adobe Web site)

One goal of the these notes is to prepare students to pass the 
ACE test in Photoshop. You will find the relevant ACE topics at 
the beginning of each chapter of these notes.

Adobe often lets students take the ACE test at a 50% discount. 
For more information, go to http://www.adobe.com/education/
educators/ace_program.html.

An Adobe Certified Instructor must pass ACE tests for 
any Adobe products he/she teaches, and either have teaching 
credentials or otherwise meet Adobe’s criteria for instructor 
excellence.

What is an Adobe Certified Training 
Center?
In an Adobe Certified Training Center, all instruction is done 
by Adobe Certified Instructors, and teaching labs meet Adobe 
standards for hardware and software.

ACE Preparation Topics

Each chapter will begin with topics from the ACE Certification 
Bulletin for Photoshop CS2.

Chapter 1: Getting started + Painting
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Painting
•	 Given a tool, paint an object by using that tool (Tools 

include: Brush Tool, Pencil Tool, Eraser).

•	 Adjust the tonal range of an image by selecting the proper 
options and using a curves adjustment layer.

•	 Explain how blending modes are used to control how 
pixels are effected when using a painting or editing tool.

•	 Create and use patterns and gradients.

•	 Create and edit a custom brush.

Using these Notes

These notes are “advanced,” meaning that we assume you 
already have at least six months working with Photoshop, or 
have taken a reasonably rigorous introductory training course. 
But, as we cover each topic, you will often see a brief review 
of what we consider the key points of the tool, command, 
or technique being covered. That is because Photoshop is a 
tough program—with so many features, options, and ways of 
accomplishing the same task—that we know you might forget 
something basic. Then, we move on to more complicated 
aspects of the topic at hand. For many of the topics, we provide 
an example file for you to open and work with as you read the 
notes. The more you experiment with each tool, command, 
palette, etc., the more proficient you will become in using 
Photoshop effectively and creatively.

Brush Tool

Brushes are used by many Photoshop tools such as the Brush, 
Pencil, Clone Stamp, Pattern Stamp, History Brush and Art 

History Brush Tools. We are going to start out by using the Brush 
Tool, called the Paintbrush in earlier versions of Photoshop, to 
show you some advanced techniques for creating, saving, and 
using custom Brush Tool settings. There are three places to view 
and change Brush options: the Options Bar, the Brush Preset 
Picker, and the Brushes palette. 

As with other Photoshop tools, the Options Bar displays the most 
common Brush settings for the chosen tool, and lets you modify 
those settings. Let’s review these options from left to right, 
and then use the 
Brushes palette to 
define and use new 
brushes.

The Tool 
Preset Picker
A Tool Preset 
captures all the 
settings for a 
particular tool, and 
saves them to use 
again. A Brush Tool preset can include a custom defined brush, 
all the Options Bar settings, and even the foreground color. Click 
the down arrow to the right of the Tool Preset Picker to view 
its preset list. By default, it is a short list.

If you click the Tool Preset Picker menu, and choose Brushes, 
towards the bottom of the menu (shown on the next page), you 
can load more brushes to work with. Be sure to choose Append 
so that the new Brush Tool Presets appears at the bottom of the 
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list, instead of replacing the current list. Then experiment with 
some of the premade Brush Tool 
presets. After you work with the other 
settings in this chapter, you can click 
the New Preset button to make Brush 
Tool presets of your own.

Brush Preset Picker

Click the down arrow to the right of 
the Brush Preset picker to view the 
palette of defined or Preset brushes. 
This palette lets you choose among 
the Preset brushes the Brush Tool or 
any other brush-using tool can employ, 
and change a few settings on the 
fly—without altering the Brush presets 
themselves.

To temporarily change the size of 
the currently chosen brush, drag the 
(Master) Diameter slider, or type in 
the desired size. Likewise, drag the 
Hardness slider from 0% for a soft or 
feathered brush to 100% for a hard or 
crisp brush. Photoshop will use these 
adjusted settings until you change tools 
(e.g., from Brush to Pencil) or pick a different preset brush.

The Presets Palette Menu lets you 
change thumbnail display, and manipulate 
brush libraries. To display the menu, press 
the triangle on the right side of the palette. 

Previews of 
the various 
thumbnails are 
shown here. 
By default 
Photoshop 
displays brushes 
by Stroke 
Thumbnail 
unless you 
are picking 
a brush tip 
shape; then it 
displays Small 
Thumbnail.

Reset Brushes restores the brushes to the default, deleting any 
custom brush presets you may have created.

The brush presets at the bottom of the menu are specialty 
brush libraries that ship with Photoshop, but are not loaded 
into the Brushes palette by default. To load one or more brush 
library, simply pick it from the menu, and then choose Append 
from the dialog box that follows. When you append a brush 
library to your list, it becomes available to any tool that uses a 
brush.
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These keyboard shortcuts will help you to change brush 
options more efficiently:

To temporarily access the Brush Preset Picker in the 
document window, click the right mouse button with 
a two button mouse or ctrl + click with a one button 
mouse.

Use the bracket keys [ and ] to the right of the P key 
on the keyboard to quickly increase ] or decrease [ the 
size of your brush.

Press Shift plus a bracket key to increase ] or decrease 
[ the hardness of the brush.

Painting Modes
We tend to think of blend modes as interactions between 
layers, but you can also use them as painting modes, 
where the colors of what you paint—the blend—interact 
with the color of the pixels currently on the layer you are 
painting on—the base—to produce the result, the colors 
that actually appear on the document. Painting modes 
all occur on the single layer you are painting on, and 
permanently alter the document pixels.

Two modes are unique to painting—but you can only use them 
on layers, not the Background, where they are dimmed.

•	 Clear will turn your brush into the Eraser, and remove pixels 
based on the brush settings. It’s not “clear” why you would 
want to do this instead of just using the Eraser tool. But, you 
can also use Clear with the Paintbucket tool, which can be a 
lot more useful.

•	 Behind works best on layers with some transparency 
because it only paints on transparent and translucent 
regions. The color will apply as long as you keep the mouse 
button down. When you release the mouse, those painted 

areas are no longer transparent, so the next stroke you paint 
will be applied behind them as well.

Colorful images work well for 
experimenting with painting 
modes. This crayon circle 
image was downloaded from 
the stock.xchng. It was taken 
by Marja Flick; Aalsmeer; NH; 
Netherlands: http://www.sxc.
hu/photo/317127.

Since painting, even with 
modes, alters the document pixels, you might want to duplicate 
the background layer before you paint.

As you experiment, try two techniques:

•	 Choose medium gray as your foreground color, and paint 
with overlay, multiply, and color dodge for interesting results.

•	 Sample colors from within the images themselves, and paint 
with a variety of modes and opacities.

Opacity, Flow, and Airbrush Options
Opacity sets the maximum amount you can see through a 
brush stroke. It controls 
the entire brush stroke. 
Without releasing the 
mouse, no matter how 
many times the painted 
area overlap, the opacity 
stays as set.

Flow determines how quickly the color paints, so that you 
end up with the specified opacity. Notice that the painted area 
darkens where it overlaps—up to the specified opacity.
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Airbrush lets you apply gradual tones to an image, simulating 
traditional airbrush techniques. Combined with low flow values, 
you can get a great deal of control over your painting, especially 
if you use a tablet and stylus instead of a mouse. You try it!

1. 	 Open up a new, blank document.

2. 	 Choose a fairly dark color.

3. 	 Select the Brush Tool and choose a medium to large brush 
size in the Brush Preset Picker

4. 	S et the Opacity in the Options Bar to 50%. If you leave the 
Brush in one spot and keep the mouse button depressed, 
the color will not get any stronger than the Opacity setting.

5. 	 Take the brush and paint over the same spot repeatedly, 
releasing the mouse after each stroke. The paint will 
accumulate until it reaches 100% of the color chosen.

6. 	 Choose the Airbrush setting in the Options Bar. Do the same 
thing you did before, keeping the mouse depressed while 
you hold the brush in the same spot. You will see that the 
Airbrush functions as a real world airbrush; the paint will 
accumulate where you pause with the Brush Tool.

Wacom is the leading manufacturer of drawing tablets. http://
www.wacom.com/productinfo/index.cfm Even the smallest 
tablet, that can usually be purchased for under $100, is very 
useful. Some of the educational software houses offer tablets 
with academic discounts.

Brushes Palette

Photoshop brushes let you simulate the effect of real world 
paint media such as oil paint, watercolors, pastels, charcoal and 
crayons. The Brushes palette provides many options for viewing, 
modifying, and creating brushes. Whenever a tool uses brushes, 

the Brushes palette button appears near the right end of the 
Options bar. You can access the Brushes Palette by clicking this 
button or by choosing Window > Brushes.

We have already looked at Brush Presets. Now let’s take a 
more in depth look the organization of the Brushes palette, 
the settings used to 
configure those presets, 
and how to change these 
settings to make your 
own custom brushes. 

The left side of the palette 
lists categories or sets of 
options, with check boxes 
to enable or disable an 
entire set. The right side 
of the palette lets you 
control the options for the 
specified set.

If your Brushes palette 
does not show the 
list of options, choose 
Expanded View from the 
Brushes palette menu.

You must click the set name, not its check box, to have the right 
side of the Brushes palette display its associated options.

Brush Tip Shapes
If you click Brush Presets, the right side of the palette will 
resemble the Brush Preset Picker. If you click Brush Tip Shape, 
the right side of the palette includes some the options shown 
above. The bottom panel shows a grayscale preview of the brush 
as a stroke thumbnail using the current palette settings.
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There are two kinds of brush tips, 
standard and sampled. Standard 
brush tips are either round or 
elliptical; sampled brush tips 
can be made from selections of any 
bitmapped Photoshop document. 
Sometimes these are called 
“custom” brush tips.

Diameter and Hardness
Diameter and Hardness settings 
work the same as in the Brush 
Preset Picker.  These samples compare different roundness 
settings. Brush sizes can range from 1-2500 pixels. When you 
make your brush tip larger, its cursor size increases. You can 
only set hardness for standard brush tips. Hardness can range 
between 0 and 100%.

Spacing
As you drag the mouse or stylus across a document with the 
Brush tool, it looks like you are applying a single stroke of paint. 
In actuality, what happens is that as you drag the mouse, the 
paint is repeatedly applied in the shape of the brush tip. The 
spacing setting determines how frequently the paint is applied.

By default, spacing is set to 25%, which means that a new brush 
tip is applied after you have moved a quarter off the original. 
This works fine for perfectly round brushes, but can cause 
unexpected results with brush tips of other shapes. 

If you want a smooth appearance to your painting, you can 
decrease the spacing setting to as low as 1%. If you want to have 
more distance between the brush tips, increase the spacing. 
Spacing can get as wide as 1000%.

Roundness and Angle Settings
Think of Roundness as the setting that can make calligraphic 
strokes. A 
100% 
Roundness 
setting 
maintains a 
brush with a 
round tip. 
Bumping down the Roundness flattens the tip, making it oval or 
in the extreme, a flat edge. You can also change the roundness 
of sampled brushes, to distort them. 

You can change the 
angle of any brush tip, 
but it will not affect 
a 100% round brush. 
The Angle setting 
rotates an oval or 
sampled brush.

Sampled Brush Tips
The preset brushes that are not round brushes such as texture 
brushes (e.g. spatter and pastel brushes), are brushes that were 
created by sampling images. You can easily create a brush from 
your own image. This process  works best with distinct shapes 
on a white or transparent background. 

Even when made from color images, brushes paint in grayscale. 
They paint with the foreground and sometimes the background 
color, depending on your brush settings. White reads as 
transparent.



Chapter 1:  Getting Started + Painting	 Page � 

Here is an example. The source file 
is butterfly.jpg in the ch01 folder 
inside the student_files_3 folder if 
you want to try it yourself.

1. 	 Open the image from which to 
sample in Photoshop, or paint 
your own brush-to-be on a white 
background.

2.	 Select the part of the image to 
become your brush, in this case the 
butterfly

3. 	 Choose Edit > Copy or  
Edit > Copy Merged for a layered 
document. 

4. 	 Open a new Photoshop document, clipboard size, and 
choose Edit > Paste.

5. 	 Choose Image > Image Size to downsample image if 
necessary. In most cases, your brush should be smaller than 
200 pixels.

6.	 Choose Edit > Define 
Brush Preset.

7. 	N ame your brush preset from 
the Brush Name dialog box.

The new brush preset will appear somewhere in the Brush 
Presets palette—not necessarily at the bottom.	

8. 	 Test your brush and adjust the Spacing if necessary. We 
made the spacing samples at the top of the next column 
by pressing the Shift key and then dragging to the right to 
make a straight stroke.

Each new sampled brush is assigned a spacing of 25%. For your 

image to be recognizable as it was sampled, increase the 
spacing to at least 100%. The leaf example shows a leaf that 
was sampled as a brush. Left, bottom shows the leaf brush 
painted with the 
default Spacing 
setting of 25%. On 
the right side, with 
the Spacing 
increased to over 
200%, a texture 
was created by painting repeatedly with the brush with different 
colors.

The Use Sample Size button appears with the Diameter setting 
in the Brushes Palette when you choose a sampled brush. This 
command activates if you change the size of a sampled brush. 
Click the Use Sample Size 
button to restore the Diameter 
setting to the original size of the sampled area. Be careful: if you 
upsample a brush tip, you degrade its quality. 

More Brush Settings

The next six listings under Brush Tip Shape offer ways of adding 
randomness, variation and taking advantage of a pressure 
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sensitive tablet. These settings 
can help make the brush 
stroke look more natural. 

•	 Click a setting name, such 
as Shape Dynamics or 
Scattering, to view the 
right side of the dialog box 
and access its settings. 

•	 Click a setting check box 
to apply the last settings 
used for that listing 
without changing the 
dialog box view to see the setting choices. 

Many of these settings have a control called Jitter. Jitter is 
variability. The higher the Jitter number, the more the brush 
stroke will change as you extend it. 

Shape Dynamics 	
Looking at the Shape Dynamics 
settings above, locate the 
Size Jitter, Angle Jitter and 
Roundness Jitter controls. 
Activating all these on a flat 
brush makes a “fuzzy” brush 
with varying size, angle and 
roundness. Size Jitter created 
a stroke with vertical spiky ends. Angle Jitter made the spiky 
ends splay out in many directions.

Minimum settings restrict the 
range that a Jitter setting can vary 
by. Here, the top brush stroke was 
painted with the brush configured in 
the previous example. Underneath 

it is the  same brush after changing the Minimum Diameter from 
0% of 83%. This reduced the amount of size variance, so the 
middle is thicker.

Each Control setting is accompanied by a drop down menu 
where you can choose various ways of limiting the Jitter. By 
default, most Controls are set to 
Off, so the Jitter settings will apply 
all the time. Two control choices, Pen 
Pressure and Pen Tilt, require a tablet and stylus. If a control 
is set to one of these settings without a tablet installed, the 
setting will display a warning triangle.

One control setting that does not 
require a tablet is Fade. Here is 
an example of Size Jitter with 
a Fade setting of 125 meaning 
that the brush stroke reduces 
in size in 125 steps or paint 
daubs until it reaches 1% of the 

brush diameter size. The Minimum Diameter was set to 1% 
(the default setting).  There are many more settings you can 
experiment with on your own that are too numerous to cover 
here. 

Check out the Scattering setting, where you can scatter the 
paint daubs vertically, or along both axes. In the example above, 
on the left the flat paint brush used in the earlier Roundness 
example was set to Scatter vertically. To the right of the Scatter 
example you can see how you can paint with texture by playing 
with the settings under Texture. Note that if you do not add 
some Spacing (click back on the Brush Tip Shape to access the 
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Spacing setting), the texture won’t show because all the textured 
paint daubs will run together as a solid stroke.

Play around with Color Dynamics where you can paint with more 
than one color such as the third example. Note that the brush 
preview at the bottom of the Brushes Palette only views your 
brush in grayscale. You will not be able to see what the color 
look like until you paint.

Under Other Dynamics you will find a setting to Jitter the 
Opacity. The Dual Brush settings will let you paint with two 
brushes at once.

The bottom 5 settings on the left side of the Brushes Palette are 
choices that you simply toggle on and off. In the right section 
of the preceding example, the Wet Edges setting was used to 
simulate using a watercolor brush, where the paint will collect at 
the edges of the brush strokes.

Your settings will be remembered by Photoshop when you next 
open the Brushes Palette. It’s easy to get so many settings 
going that you may at some point want to start over from the 
defaults. To quickly turn off all the settings but Smoothing for 
a particular brush to its defaults, choose Clear Brush Controls 
from the Brushes Palette pop-out menu, the tiny triangle next to 
the word Brushes.

Saving Brush Presets

Any time that you choose a brush from the presets and then 
make changes to it, in effect you have created a new brush. The 
preset has not been changed; it will always give you the same 
settings when you click on it. If you click on any preset, your 
customized brush will disappear. If you want to save a brush that 
you have customized, you can do it in a number of ways.

To save a brush as a new preset, you can click on the New 

Brush Preset button in the Brush Preset Picker or choose 
New Brush from the pop-out menu of either the Brushes 
Palette or Brush Preset Picker. Either way, Photoshop will 
automatically name the brush based on the preset you started 
with. You will have the option to change the name when you 
save the brush. Your new brush will show up somewhere—not 
necessarily at the bottom—of the Brush Preset Picker and the 
preset area of the Brushes palette.

Be aware that your brush is not saved forever. Any of the 
following will wipe out your customized preset brush:

•	 Choosing Reset Brushes from the pop-out menu of either 
the Brushes Palette or Brush Preset Picker.

•	 Choosing Replace Brushes from the pop-out menu of 
either the Brushes Palette or Brush Preset Picker.

•	 Choose a brush library from the list in the pop-out menu of 
either the Brushes Palette or Brush Preset Picker and choose 
to Replace in the dialog box (which is the dangerous 
default) by clicking OK.

To save your brushes more permanently, you have two choices: 
to save a new library of brushes, or save an individual brush as a 
tool preset.

To save a new Brush library 
1. 	 From the Brushes Palette, make sure that the Brush 

Presets is highlighted at the top, left of the Brushes palette.

2. 	 Choose the Save Brushes command from the Brushes 
palette pop-out menu or the Brush Preset Picker menu.

3. 	 Enter a name for the new brush library. The extension .abr 
for a brush library will already be entered.

4. 	 Browse to where you want to save the Brushes. By default it 
will be set up to save in the Adobe Photoshop Only folder 
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inside the Brushes folder hidden inside the Presets folder 
inside your Adobe Photoshop CS2 application folder. 

If you don’t change your save location, when you re-launch 
Photoshop, your new brush library will be a choice in the pop-out 
menu of both the Brushes Palette and Brush Preset Picker. If you 
don’t want to re-launch, you can use the Load Brushes command 
from the pop-out menu. Saving a library will save all the preset 
brushes currently showing in the Brush Presets of the Brushes 
Palette or the Brush Preset Picker into the library.

It is also a good idea to save an additional copy of an important 
brush library elsewhere on your computer—this way it won’t 
get accidentally deleted when you next upgrade your copy of 
Photoshop.

To save a brush as a Tool Preset
1. 	 With the Brush Tool chosen (or whatever tool you want to 

save the brush for), in the Options Bar, click on the arrow next 
to the Current Tool icon to open the Tool Preset Picker.

2. 	 Click on the check box next to Current Tool Only at the 
bottom of the Picker.

3. 	 Click the Create New 
Tool Preset button that looks like a page icon. 

A dialog box appears.

4. 	 Click the Include Color check box if you want to include 
the current Foreground color with the preset.

5.	 Click OK.

Saving a Tool Preset will make it easy to choose this precisely 
formatted brush from the Tool Preset Picker. The brush will not 
appear in the Brush Preset Picker or Brushes Palette. You can 
also save the tool preset as a Tool Preset Library, as shown at 
the end of this chapter.

Loading, Downloading, and Sharing 
Brushes
Because you save brushes to a file when you save your brushes 
as a library, you can easily share your brushes with others, or 
travel with your brushes from one computer to another.

The .abr file that you create when you save your brushes to a 
library can be saved anywhere on your hard drive, on removable 
media such as a zip disk or a CD, or you can even send them via 
email as an attachment.

As stated earlier, when you save your .abr libraries of brushes to 
the Adobe Photoshop preset folder, the name of the library will 
appear in the list of libraries in the pop-out menu of the Brushes 
Palette or Brush Preset Picker. If you save somewhere else, you 
can easily load up the library by choosing Load Brushes from 
the pop-out menu. You will be given the choice to browse to 
where your .abr file is located.

If you explore the Internet, you will find sites that offer up 
Photoshop brushes free for the downloading. Our favorite is: 
Adobe Studio Exchange: http://share.studio.adobe.com/
Default.asp. There you can download actions, brushes, custom 
shapes, gradients, patterns, styles, etc. You will need to establish 
a user name and password in order to download, but it won’t 
cost you any money—and you won’t get piles of junk email. For 
custom brushes, choose Brushes from the Adobe Photoshop area.

The Pencil Tool

The Pencil tool differs from the 
Brush Tool in one key way. The 
Pencil always paints hard-edged, non anti-aliased lines or areas. 
The Brush Tool always paints with anti-aliasing, even at 100% 
hardness.
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Pixel Editing
The Pencil tool is best used for drawing a straight 
line or editing on a pixel by pixel basis. For example, 
in the extreme close-up view of this illustration, the 
Pencil tool could be set to draw with a one pixel width brush 
making it easy to edit the two stray pixels next to the arrow, 
making them brown.

Fill Tools 

Fill Tools replace an entire layer or a selected area with a 
color, pattern, or gradient.

Paint Bucket Tool
The Paint Bucket tool fills a layer or selection with the 
foreground color or a pattern.

Change the Fill choice to toggle between the foreground color 
or a pattern. When you choose Pattern, the last pattern used 
appears in the Pattern box. Mode and Opacity control how 
the color or pattern will paint.

When the layer/selection contains pixels of varying colors or 
tones, Tolerance controls how the Paint Bucket will fill the 
selection. The star in the left bear head shows where the Paint 
Bucket clicked with the hot pink 
foreground color. The middle bear 
head was filled with the tolerance 
set to 32, the right bear with a 
tolerance of 150.

Like all other tools, the Paint Bucket can only change pixels on 
an individual layer. When Use All Layers is checked, tolerance 
applies to all visible document layers.

Even with tolerance to the max (255), you may need to click 
the Paint Bucket more than once to completely fill an area. 
Some Photoshop experts, such as Deke McClelland, recommend 
avoiding the Paint Bucket tool because it is so hard to set its 
tolerance to fill the area you want. Instead, choose Edit > Fill 
and fill 100% to fill a selection completely in one step.

The Gradient Tool
The Gradient tool paints transitions of color or tone across a 
layer or a selection. At 100% opacity in Normal painting mode, 
the gradient will replace all the pixels currently on the active 
layer or selection.

By default, the Gradient tool draws gradients using the 
foreground and background colors displayed in the Toolbox, 
using the Linear Gradient style. Results depend on where and 
for what distance you set the angle and length as you drag the 
tool across the document. These examples use a linear gradient 
from red to blue at 100% 
opacity.

The Gradient tool has 
five style options, Linear, Radial, Reflected, Angle, and 
Diamond, as shown on the Options bar. You’ve already seen 
samples of the linear gradient. Here are the other four:

     Radial 	 Angle 	       Reflected 	   Diamond
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The Reverse option (not checked above) paints the 
gradient from right to left instead of the default left to right.

When checked, Dither minimizes banding or striping in the 
gradient, especially when it is printed.

If Transparency is not checked, the gradient will paint with 
solid color, without any transparent regions—even if they are 
edited into the gradient.

Gradients are particularly effective when placed on their own 
layers and blended with other layers. To get more experience 
with the possibilities the gradient tool provides, try making a 
Photoshop document using nothing but gradients. Here are 
examples from some of our students:

 	

 	

 	

Gradients

Gradients are gradual transitions between 
specified colors. The Gradient tool, the Gradient 
Overlay layer effect, and Gradient Fill layers all 
use gradients.

Like brushes, Photoshop has additional gradient 
libraries that you can load from the Gradient 
Picker pop-out menu. Besides being useful 
on their own, they give you examples from 
which to construct your own custom gradients. 
Typically you will want to begin with a gradient 
similar to the one you want to make, and edit it.

To edit a 
gradient
1. 	 Choose the 

Gradient tool.

2. 	 Click the 
gradient preview in the Options bar to open the Gradient 
Editor.

3. 	 Edit the gradient as you choose. Suggestions follow these 
instructions.

4. 	 Rename the gradient if desired. The default name of an 
edited gradient in the Name box is Custom.

5. 	 Click the New button. Your new gradient will appear at the 
end of the Gradient Picker.
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Gradient Editor Specifics
The Gradient Editor shows a large sample of your gradient as a 
bar across the middle of the palette. The little polygon shapes 
at the top and bottom of the gradient bar are called Stops. The 
Opacity Stops on the top of the sample set opacity. The Color 
Stops on the bottom of the sample set colors.

To change gradient color, click its color stop to select it. When 
it is selected, its triangle will become black. Then, either click a 
color from an underlying open image or click the Color box to 
choose a color from the Color Picker.

Drag individual color stops to affect how much of a chosen 
color will fill the gradient bar. Drag the little midpoint diamond 
between the stops to control where the blending midpoint of the 
blending between the two colors will be. (You will only see the 
diamond, when a color stop is active.)

 To add a color stop, click in a blank area underneath the 
gradient bar to add a stop. Then change its color by either 
click a color from an underlying open image or click the 
Color box to choose a color from the Color Picker.

To remove a Color stop, drag it below the gradient bar.

You can edit the Opacity stops above the gradient bar much like 
the Color stops. The Opacity box at the bottom of the dialog 
box lets you set opacity from 0-100%. Less than 100% opacity 
shows as a gray checkerboard in the gradient bar. Bands of 

zero opacity make gradients with bands of color. Check out this 
tutorial in three pages for more gradient instruction:

http://www.planetphotoshop.com/tutorials/PeteBauer38.html 
http://www.planetphotoshop.com/tutorials/PeteBauer39.html  
http://www.planetphotoshop.com/tutorials/PeteBauer40.html

Clone Stamp Tool

The Clone Stamp and Pattern 
Stamp tools are grouped 
together in the toolbox. The 
tool icons are so similar it is easy to confuse them.

The Clone Stamp tool lets you paint with images. It uses 
brushes to selectively copy from one area of an image to 
another, or from one image to 
another. A common use of the Clone 
Stamp tool is to paint out unwanted 
parts of an image, by using other 
parts of the image.

For example you can use the 
Clone Stamp Tool to paint out 
high wires. The starting image is 
“Telegraph Road” by Evert-Jan van 
Scherpenzeel, Amsterdam, Noord 
Holland, Netherlands. http://www.sxc.
hu/photo/175753  According to the 
stockxchng web site, he shot the image “from a train somewhere 
between Groningen and Zwolle.”

We don’t recommend that you remove wires from an image 
like this, where the wires form such an integral part of the 
photograph, but a close up of the top of the telegraph pole 
provides a good learning example.
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If you were painting out 
the wires, you probably 
would do most of the work 
with the Healing Brush 
or Spot Healing Brush 
Tools. However, those tools 
work by trying to match 
the tones of the underlying 
image about 20 pixels 
beyond the outline of the brush 
tip, and they have trouble when 
they get too close to a sharp 
change in tonality.

Notice the smudging on the 
side of the telegraph frame, 
where the wire was removed 
with the Spot Healing Brush. Here’s how to finish the repair:

1. 	 Make a new layer to hold your cloning, so you don’t clone 
over the original image pixels. Better to be safe!! 

2. 	 Choose the Clone Stamp tool and set its options.

 	 Aligned is unchecked so that we can sample the sky color 
once, and paint it 
several times. It is best 
to clone in short strokes 
to get effective coverage. 

Sample All Layers is checked so that we can use the 
composite of all visible layers as our source.

3. 	 Choose a small soft brush.

4. 	 Alt + Click (Windows) or Option 
+ Click (Mac) to set your source 
point. 

If you forget to set 
your source point, 
you will see this 
warning:

5. 	 Clone-paint onto 
the blank layer to protect the original. This image was very 
easy to clone because the sky is so uniform in color. If the 
image had more detail 
across the wires, it 
would have been more 
time-consuming.

For a real cloning challenge, 
try removing the wires and 
the pole from this grayscale 
photograph of a photograph 
of the Sonoma Hotel in Sonoma, California that was originally 
taken in the 
1920’s.

The picture 
was originally 
taken before 
there were 
underground 
utilities, and 
these wires 
detract from, 
rather than 
enhance the image.

Located in ch01 of the 
student_files_3 on the 
notes CD, the file is named 
sonomahotel.jpg.
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Another common use of the Clone Stamp tool is to clone from 
one open document to another as shown with these cats eyes. 

Here you can see the distinction between cloning with aligned 
on (checked) or off. With Aligned on, or checked, you paint 
in alignment with the original sampled spot. With Aligned off 
or unchecked, each time you begin making a brush stroke, you 
start again from the sampled area.

The middle image shows Clone tool painting with Aligned on. 
The left eye was the sample spot from the image on the left. 
The eye was painted in and then the cursor was moved before 
continuing to paint, which ended up painting in the nose in 
alignment with the eye as in the original image. On the right 
example, Aligned was turned off. The first eye was painted in as 
in the Align On example. Moving the cursor and painting with 
the brush again caused the same sample of the left eye to be 
painted in. 

To experiment with clone stamp settings on your own, make an 
eye image.

1. 	B egin with the file called cat_eyes.psd. It is inside the 
ch01 folder inside the student_files_3 folder.

2. 	M ake a new document and fill it with a gradient or pattern of 
your choice.

3. 	 With Aligned unchecked, set the source point at the center 
of the cat’s left eye,

4. 	U se a big enough brush to clone the entire eye in one click, 
like 80 pts., and set brush hardness to zero

5. 	 With just a click of the mouse, clone from the left cat image 
onto your second image.

6. 	 Repeat steps 4 and 5, setting brush hardness to 100%, and 
then repeat at 75% and 50%.

7. 	N ow go eye-stamp crazy. Experiment with aligned on and off 
as you click or drag to paint eyes or more of the kitty. Then, 
change the Clone Stamp painting mode in the Options Bar, 
and see the results.

Pattern Stamp Tool

The Pattern Stamp tool, hiding under the Clone Stamp tool, 
paints with the pattern of your choice, chosen from the Pattern 
Picker accessed from the Options Bar. Small, subtle patterns are 
often used for retouching; large patterns are used for painting 
and decoration. Try pattern-painting with the some of the 
texture patterns, especially at varying opacities.

Patterns
A pattern is a square or rectangular swatch that repeats or 
tiles throughout a layer or selection. Patterns are used by the 
Pattern Stamp tool, the Paint Bucket tool with the pattern option 
chosen, the Pattern Overlay layer effect, Pattern Fill layers or 
when choosing Edit > Fill and filling with a pattern. Patterns are 
organized in the Pattern Picker.

One way to view the Patterns picker:

1. 	 Choose the Pattern Stamp tool (under the Clone Stamp 
tool by default).

2. 	 Click the triangle next to the Pattern preview in the options 
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bar to view the Pattern Picker.

Like gradients, you can load and use 
additional pattern libraries from the 
Pattern Picker menu. You can also 
define your own patterns. There 
are two ways to define patterns, 
either by rectangular selection or 
by using the Pattern Maker Filter. 
These patterns were made using the 
butterfly.jpg image inside the ch01 
folder inside the student_files_3 
folder.

To define a pattern by 
selection
1. 	 With the rectangular marquee, 

select the area to become your 
tile, like this section of butterfly.

2. 	 Choose Edit > 
Define Pattern.

3. 	N ame the pattern 
in the Pattern 
Name dialog box 
that appears, and 
click OK.

The pattern will appear at the end of the Pattern Picker.

 4. 	Use your pattern. 

The left sample was painted with the Pattern Stamp tool, and 
the right sample was filled using the Paintbucket tool.

The Pattern Maker Filter
The Pattern Maker filter can generate many variations of a 
pattern by reshuffling pixels from a selected area. You can either 
use this filter to fill your layer with the pattern or use it to define 
a preset pattern to use with the tools and commands that use 
patterns. To use the Pattern Maker filter, find an image where 
you like the colors and overall texture. You can select an area 
with the Rectangular Marquee tool or select the whole layer.

If you want to replace the layer with the pattern, you should 
copy the layer before selecting the filter or copy the selected 
area to the clipboard and create a new layer for the pattern.

Once you have chosen Filter > Pattern Maker, you will be 
presented with a large dialog 
box. If you haven’t made a 
selection, you can make it inside 
the dialog box. You can move the 
selection marquee around in the 
image display. If you copied your 
selection to the Clipboard, click the 
Use Clipboard as Sample check 
box.

You control the size of the 
patterned tiles by setting the 
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Width and Height sliders in the Tile Generation area. The 
default is 128 pixels for each. Click on the Use Image Size 
button to generate one tile the same size as your image. 
Under the Width and Height, the Offset drop down menu 
allows you to offset the tiles horizontally or vertically.  Offset 
and Smoothness can lessen the visibility of the tile seams. 
Increasing Smoothness will lower the contrast of the next 
generated pattern.

Click the Generate button at the top, right of the dialog box 
and the large display area will fill with a pattern generated by 
the selected area. On the bottom right corner of the dialog box 
under Tile History, you will see a sample tile.

The Generate button now changes to Generate Again. You can 
click on Generate Again repeatedly and each time you will get a 
different display and a different sample tile. Each time you hit 
the Generate Again buttons, a sample tile is generated and 
stored Tile History area.

Under the sample preview in the 
Tile History area, you can hit 
the arrow keys to cycle through 
the various versions you have 
generated, up to 20 tiles. Once 
you go beyond 20, the first ones 
will be deleted. To delete an 
unwanted tile, navigate to it and 
click the Trash button in the Tile 
History area.

When you see a pattern you like, click the very small Save 
Preset Pattern button (looks like 
a floppy disk) on the left side of Tile 
History. This will save the pattern to the 
Pattern Preset Picker where you can use 
it with any tools and commands that 

offer a pattern option.

Each time you click the Save Preset Pattern button, you save 
a single tile, not the whole pattern shown in the large display 
area of the dialog box. You can choose to save as many of the 
sample tiles as you want. This butterfly pattern was generated 
from a small piece of the butterfly wing. Notice that tile borders 
are much less apparent when using the Pattern Maker filter.

WARNING: Click Cancel after you save your preset patterns 
to avoid replacing your entire currently active layer with the 
pattern. Only click OK or press Enter if you want to replace the 
entire original layer with the pattern seen in the filter window.

The Eraser Tools

Photoshop has three Eraser 
tools: the (standard) Eraser, the 
Background Eraser, and the Magic Eraser. You might want to 
open pumpkin.jpg in ch01 in the student_files3 folder and use 
this image to compare the use of the three Eraser Tools and 
their options.

Eraser Tool
The (standard) Eraser tool paints with the background color on 
the Background layer, and erases to transparent on other layers.

Mode determines the brush shape and properties. As you 
change from one mode to another, the Options Bar settings 
will change to reflect that mode’s available options.

Brush and Pencil modes use brushes to paint with the 
background color or transparency. Brush mode erases using 
anti-aliasing; pencil mode does not.

Block changes the eraser to a square, hard-edged, fixed-
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size eraser. Use Block mode to completely erase areas, or to 
fine-tune a highly-magnified image. As you zoom in, Block 
covers fewer pixels; it is zoom level dependent.

The Erase to History option (not shown above) lets you 
restore areas on the current layer from a History palette 
state. It only works when the current document and the 
History state have the same number of layers, and the 
image has not been resized.

Magic Eraser Tool
The Magic Eraser tool is like first clicking—not dragging—with 
the Magic Wand and then pressing the delete key to erase the 
selected area to transparent pixels. Its options resemble those of 
the Magic Wand.

Tolerance controls the range of tonality from the clicked 
pixel to be removed.

Contiguous erases only neighboring pixels.

Use All Layers bases the selection on the composite image 
tonality rather than that of the active layer—but will only 
remove pixels from the active layer.

Anti-aliased gives a softer edge to the selected area.

Opacity below 100% lets you partially erase parts of a layer.

When you Magic Erase the Background layer, it automatically 
becomes a standard layer to support transparency.

To use the Magic Eraser:

1. 	 Activate the layer with the pixels you wish to erase; you can 
only erase pixels on one layer at a time.

2. 	 Set your options

3. 	 Carefully position the cross hair pointer over an area with 
the color you wish to erase.

4.  Click once to erase.

If the Magic Eraser does not perform as you had hoped, undo, 
adjust your tolerance, and try again. Many Photoshop authors 
recommend avoid the Magic Eraser because it is so primitive, 
preferring the enhanced control of the Background Eraser or the 
Image > Extract dialog box.

Background Eraser
The Background Eraser tool lets you erase pixels on a layer 
as you drag. By specifying different sampling and tolerance 
options, you can control the range of background removal and 
the sharpness of the removal boundary. The Photoshop Wow 
book describes it as “the Extract command on a wand.”

To use the Background Eraser:

1. Activate the layer with the pixels you wish to erase; you can 
only erase pixels on one layer at a time.

2. Set your options

Limits control where erasure occurs. 

•	 Contiguous erases areas of the sampled color 
connected to one another. 

•	 Discontiguous erases the sampled color wherever it 
occurs in the layer within the limits of the brush shape. 

Find Edges erases connected areas containing the sampled 
color while better preserving the sharpness of the object’s 
edges. This setting works best with high contrast borders.



Chapter 1:  Getting Started + Painting	 Page 19 

Tolerance is similar to the Magic Wand, but measured in 
percentage (0 to 100%) rather than 256 levels.

Sampling controls how the erasure color is chosen. 

•	 Continuous adjusts erasure as you drag across 
different image pixels. 

•	 Once only erases pixels that match the first pixel you 
drag across.

When Protect Foreground Color is checked, pixels of the 
foreground color will not be erased. This option works best 
when Sampling is set to Once.

3. 	 Choose your brush.

4. 	 Drag to erase. The plus in the center of the brush is the 
hot spot. With a soft-edged brush, erasure will be more 
complete at the center of the brush than towards its edges.

With Limits set to Continuous, the Background Eraser 
removes all the pixels in its swath, that are within the tolerance 
of the pixels it passes over. In other words, each pixel that 
passes under the center of the brush adds to the range of pixels 
to be deleted.

With Sampling set to Once, the Background Eraser only 
removes pixels within the tolerance of the color under the hot 
spot when you first pressed the mouse. Each time you release 
the mouse button, move its location, and press again, you 
redefine the hot spot color.

Eraser Cautions
All the Eraser Tools permanently remove pixels from the active 
layer. If you are unsure exactly what you want to erase, use a 
layer mask instead of erasing (Chapter 5 notes).

Although you can select pixels from individual layers or the 

composite image (Use All Layers), you can only erase pixels or 
remove backgrounds from individual layers.

The Magic and Background Erasers change the Background layer 
into a regular layer, and erase to transparent—not always in the 
way you hoped. Before using one of these tools, you may want 
to preserve an intact copy of either the layer or the image.

Web Graphics Preparation 
Guidelines

Many of you who are reading these notes are enrolled in 
a course where you submit some or all of your Photoshop 
documents to your instructor as electronic files. While online 
submission is very convenient for students, we ask that you 
follow the file preparation and submission instructions carefully. 
The bigger a file, the longer it takes to send or receive.

But this section is also applicable to those of you who are 
reading the notes independently. Nearly everyone, these days, 
sends graphics files over the Internet. These instructions will 
help you to prepare appropriately-sized images.

As you know, Photoshop files with enough pixels for printing, 
are big files—often many megabytes. This table gives sample 
transmission times for a 100 KB file.

Service Type Download Time

28.8 k modem 28 seconds

56 k modem 14 seconds

Broadband: ISDN, DSL, Cable 6-12 seconds

T1 Less than 1 second
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Why should you shrink pixel dimensions 
for a web or email graphic?
Older Web browsers do not have zoom tools—all graphics are 
seen at 100%. If an image has more pixels than the monitor 
can display, the browser typically can’t show the entire image 
without scrolling. You see the upper left corner of the image, 
and have to scroll to see the other parts.

So, you want to preserve your high-pixel image for printing, and 
make a smaller pixel copy for screen.

When you send a file over the Internet, either attached to an 
email message or uploaded to a Web page, big files can cause 
three kinds of problems.

1.	 Big files take a long time for you to send (upload) 
and for the recipient to receive (download). 

If you sent someone a 24 mb file, it might take twenty 
minutes for them to receive it if they use a modem to 
connect to the Internet (dialup connection) and maybe twice 
as long for you to send the file with a dialup modem.

2.	 Big files can cause problems with Internet Service 
Providers. 

Each Internet Service Provider typically gives each client 
a small amount of space, like 2-10 MB, to store all your 
downloaded files. If someone sends you a 24 MB file, or a 
bunch of people send you 1 MB files, you can quickly run 
out of room, and your provider may stop serving you. If 
students send their instructor large files, that instructor’s 
email capabilities may be turned off until the inappropriately 
big files are deleted.

3.	 Big files don’t display well in Web pages.

That’s because they take so long to become visible, and 
because they have more pixels than the width of the monitor. 

Your goal is to make files that can be viewed as an email 
attachment or in a Web browser without scrolling. The 
smallest standard monitors are 640 pixels wide and 480 
pixels high. Monitors, thus, are landscape (wider than they 
are tall). Even for folks with larger monitors, operating 
system and browser controls such as menus and scroll bars 
take some room on the screen. To allow for those controls, 
try to keep your Web and emailed images in this course 
around 600 pixels in their largest dimension. 

How big is your file?
When we talk about the size of an image, we can refer to the 
document size which reflects the size an image would print 
out (inches), or we can refer to the file size: the number of 
bytes, kilobytes, or megabytes an image takes up on a hard 
drive or disk. A bit is the smallest unit of information on a 
computer. A byte is made up of 8 bits. A kilobyte (K) is 
roughly 1,000 bytes (1,024) and a megabyte (MB) is 1,024 
kilobytes.

When you compress an image to send by email or put up on the 
web, you need a small file that will download quickly. Usually, 
you will be looking at kilobytes (K) unless the image is extremely 
small, than it will be in bytes.

Make sure that you closely watch how big (file size) your image 
is. Unless otherwise specified, your web or emailed files should 
be under 100 K. If you want to check the size of a file after you 
make it, view its Properties (Windows) or Get Info (Mac) from 
the desktop. When you open a compressed file in Photoshop, it 
temporarily expands for editing. Thus a 48 kb jpeg opens to 703 
kb if you check the file size on the Status bar.

Also watch those pixel dimensions (document size), and keep 
them below 600 pixels in the largest direction for files to be 
electronically transmitted.
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Here is a guided exercise we wrote for our introductory students, 
but we think it may benefit many of you as well:

Guided Exercise 1.1: Save a 
Duplicate File for the Web

1. 	B egin with the file called pumpkin1.psd. It is inside the 
ch01 folder inside the student_files_3 folder.

2. 	 Choose File > Save for Web.

The dialog box may open very slowly if the source file is a 
large one. Save for Web will show one of four different views, 
identified by the highlighted tab in the upper left region of 
the dialog box. 

Original shows only the original file.

Optimized shows only the preview of the Web file with its 
current optimization settings.

2-Up, shown here, splits the image preview into two panes, 
with the left one showing the original and the right one the 
optimized view, for easy comparison.

4-Up displays four versions of the image. The upper left 
image is the original. The upper right image is highlighted, 
as indicated by the black line around its preview.    	

3. 	 Choose the 2-up view, if it is not already visible.

4.	 Reduce the number of pixels in the Web copy of the image 
to reduce its file size.

a.	 Click the Image Size tab 
on the right side of the 
dialog box.

b.	 Change whichever 
dimension is larger, width 
here, to 600 pixels.

When you type in the new 
width, the other values 
in the Image Size tab 
recalculate. This image will become 25% of its original 
size when the new size is applied.

c.	 Choose the Quality Photoshop should use to change the 
Image Size. Bicubic Sharper, shown here, will usually 
give the best results when you shrink an image.

d.	 Click the Apply button to change the image size. You will 
notice that you will be able to see more of your image in 
each of the panes in the dialog box.

Note: you must click Apply, not press the Enter or Return 
keys on the keyboard. If the preview image does not 
shrink, you have not done it properly. Redo step 4c.

5.	 Check your file size.
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The bottom of each preview pane displays the type of format 
(JPEG here), the size the file will be on disk when you save 
it using those settings, and how long it will take to send over 
the Internet.

6.	 Set your settings 
to match the ones 
shown here.

JPEG (not GIF).

Quality setting 
should typically be 60 or High. 

If your file is still larger than 99 KB, then gradually lower 
your Quality to 55 or 50, or still lower if necessary.

Progressive and ICC Profile should be unchecked.

6.	 Click Save to save the image using your chosen settings.

In the Save Optimized As dialog box that pops up next, 
notice that the image is already appended with .jpg.

7.	N ame your file, make sure you are saving the file in the 
correct location by using the top drop down menu, and click 
Save.

When you name files for Web or email use, try to keep the 
names short (under 10 characters) and avoid spaces or 
punctuation in the file names.

The JPEG will be saved to the place you designated with the 
original, unchanged, document still open.

Resolution Review

Still having trouble understanding resolution? The Adobe 
Evangelists recognize how hard it is to grasp the relationship 
between image size, file size, and resolution. Here are a few of 
their PDFs that should help.

Image Size - Common Questions 
www.adobeevangelists.com/pdfs/pscs2/imagesize.pdf

And, some examples: www.adobeevangelists.com/pdfs/
photoshop/tipsandtricks/resolution.pdf.


